Tag Archiv: adobe

Adobe Flash 64-bit

Неделю назад назад компания Adobe выпустила бета-версию Flash Player 11 для 64-битных Linux-систем. Напомним, что ранее пользователям Linux  приходилось довольствоваться 32-битной версией или же альтернативными Flash-плеерами.
От новой версии ожидается, в первую очередь, прирост производительности при работе. Кроме того, заявлен ряд новых функций, среди которых  отдельно стоит назвать програмное кодирование H.264.
Пользователи Ubuntu могут установить  Flash Player 11 beta из PPA, выполнив эту команду:

sudo add-apt-repository ppa:sevenmachines/flash && sudo apt-get update && sudo apt-get install flashplugin64-installer

Немного об интернет-мессенджерах

В последнее время довольно тихий обычно сегмент интернет-мессенджеров всколыхнуло несколько новостей. 
Пожалуй, наиболее всколыхнувшей весь интернет новостью, была покупка Skype Microsoft‘ом за $8,5 млрд.  Интернет-аудитория практически единодушна во мнение, что данное событие принесёт только негатив. Если недавний выход новой Linux-версии 2.2 после слухов о прекращении поддержи данной ОС дали надежду на продолжение разработок под Linux, то с покупкой Skype Microsoft‘ом большинство снова ставит крест на новых Linux версиях. 
Однако, даже если отбросить вопрос поддержки Linux, всё-равно многие опасаются потери главного преимущества Skype — отличной защищенности каналов. Если Skype ранее была известна своими конфликтами со спецслужбами ряда стран в вопросе конфиденциальности каналов связи, то с приходом Microsoft,  которая известна своей чрезмерной лояльностью к спецслужбам,  это преимущество может сойти на нет.

Первые «ласточки» присутствия Microsoft уже появились: вначале было объявлено о прекращении распространения Skype для Asterisk, который предназначался для интеграции Skype  с  другими VoIP-продуктами,  а на днях многие пользователи Skype для различных платформ испытали проблемы с работоспособностью клиента. 
В Linux  для решения проблемы предлагают следующее: 

mv ~/.Skype/shared.xml ~/.Skype/shared~.xml


На фоне упомянутых новостей намного позитивнее воспринята интернет-сообществом информация о выходе официального ICQ-клиента под Linux.
Однако и здесь не всё хорошо: во-первых, в качестве платформы для распространения на MacOS и Linux выбрана Adobe AIR; во-вторых, пока разработчиком поддерживаются лишь считанные дистрибутивы и даже их версии (например, я в Ubuntu 11.04 при запуске установленной ICQ получал белый прямоугольник на экране, где, судя по всему, должен был быть контакт лист и пиктограмму ICQ на панели, которая не реагировала на нажатия); в-третьих, минимальные требования (например, 1 ГБ ОЗУ) для интернет-менеджера ничего кроме удивления и смеха не вызывают.
И всё же внимание ICQ к Linux может как порадовать так и насторожить: хотя недавние конфликты с альтернативными клиентами (смена версии протокола разработчиком) уже затихли, они могут набрать новую силу, учитывая, что одной из претензией со стороны пользователей альтернативных клиентов был аргумент про то, что официальные клиенты под ряд платформ просто отсутствует.
Таким образом, несколько позже ICQ вполне может отчитаться о том, что теперь официальные клиенты доступны практически для любых платформ (благодаря Adobe AIR) и вновь вернуться к практике блокировки альтернативных клиентов.
Пользователи вновь на перепутье: после шумихи с альтернативными клиентами ICQ многие стали искать альтернативу, и, главным образом, этой альтернативой становился Skype, в первую очередь, благодаря защищенности канала и несговорчивости разработчиков со спецслужбами. 
При владельце Microsoft  (в особенности, если в ближайшее время нам преподнесут новые «сюрпризы») проблема выбора вновь станет актуальной. 
Исключив малораспространенные  у нас мессенджеры вроде Yahoo Messenger, мы вновь возвращаемся к XMPP aka jabber. Этот протокол используется всё шире и шире, причём разными компаниями. Однако, здесь проблемой является низкая осведомлённость пользователей об используемом ими протоколе. Например, пользователь GTalk может и не знать о том, что он может просто добавить пользователя QIP-XMPP или же Mail.ru Agent и т.д., что в свою очередь, ограничивает круг общения лишь пользователями конкретной сети, т.к. разработчик клиента не видит для себя выгоды популяризировать собственно протокол, а не клиент.
И всё же, думаю, в ближайшее время мы окажемся свидетелями развития новых событий вокруг Skype и ICQ, и кто знает, быть может в сегменте мессенджеров появится и новый игрок, который сможет изменить расстановку сил, а может всё-таки и настанет уже давно многими предсказываемое превалирование jabber’а.

Adobe AIR в Ubuntu 64-bit

Одной из существующих платформ для работы веб-приложений является Adobe AIR. Рано или поздно, возможно, вам придётся столкнуться с одним из таких приложений, которые потребуют установки Adobe AIR.
Если для 32-битной системы особых проблем не возникает при установке AIR с сайта Adobe, то для 64-битной требуется некоторая подготовка. К сожалению, представленный на странице загрузки deb-пакет рассчитан на установку только в 32-битную систему. 

Для установки же в 64-битную систему нам необходимо использовать инсталлятор (bin), предварительно установив поддержку 32-битных библиотек:
sudo apt-get install ia32-libs

После чего, скачаем инсталлятор, и поместим (для удобства) его в домашний каталог.

Поставим права выполнения для файла

chmod 777 ~/AdobeAIRInstaller.bin

и запустим его из домашнего каталога

./AdobeAIRInstaller.bin

После этого вы можете запустить Adobe AIR в меню «Инструменты» и вручную указать предварительно скачанный файл с приложением AIR.

Однако, чтобы избежать ненужных манипуляций, довольно часто предлагается запуск установки сразу со страницы приложения. В этом случае, необходимо указать путь к Adobe AIR.
Рассмотрим это на примере Mozilla Firefox.
При первой загрузке AIR приложения браузер спросит о требуемом действии («Открыть в…» / «Сохранить»). Выберем  приложение в «Открыть в…». Необходимый нам файл находится в /usr/bin/  (см. скриншот ниже)
После выбора установщика для открытия AIR-приложений нажимаем OK.

Ищем замену Adobe Flash: Lightspark, Gnash, Swfdec

На днях было объявлено о выходе новой версии альтернативного Flash-плеера Lightspark 0.4.5. 
Пользуясь случаем, рассмотрим 3 альтернативы для AdobeFlash: Lightspark, Gnash и SwfDec. Хотя в интернете уже вовсю трубят о скорой гегемонии HTML5, сегодня поддержка Flash нужна все еще многим.
Предполагаем, что используется браузер Firefox, поэтому результаты тестирования и установка плагинов будет рассмотрена для него.

Также перед установкой каждого из пакетов рекомендуется удалить альтернативные и собственно Adobe Flash, например
sudo apt-get remove flashplugin-nonfree fflashplayer-mozilla flashplugin
ну и указанные ниже пакеты, если какие-то были установлены. Это действие не является обязательным, но желательным. Ну и само собой, перезапустить браузер.
 
Lightspark. В частности, среди преимуществ этого пакета называют следующее:


За счет тесного использования OpenGL и JIT-компиляции нагрузка на систему при работе Lightspark заметно меньше, чем при просмотре того же ролика в Gnash или Adobe Flash. Проект развивается при поддержке организации GNOME Foundation. 
Ключевым новшеством представленного выпуска является переход на использование нового графического движка, позволяющего обеспечить более качественное и быстрое отображение графики, уменьшив при этом нагрузку на CPU. Новая графическая архитектура построена по комбинированной схеме, в которой использованы и программные методы формирования изображения (вывод геометрических примитивов через Cairo, используя многопоточную схему обработки) и аппаратные механизмы акселерации (декодирование видео с использованием Pixel Buffer Objects; задействование OpenGL для работы фильтров и эффектов).

Вторым важным новшеством является полный редизайн системы ввода, что позволило добиться работоспособности кнопок Play/Pause при просмотре YouTube-роликов.

Следует сказать, что сам Lightspark основан на Gnash, о котором речь пойдет ниже.
Для установки последней версии Lightspark нам необходимо добавить РРА-репозиторий:
sudo apt-add-repository ppa:sssup/sssup-ppa

 Обновим список пакетов:

sudo aptitude update 

или

sudo apt-get update

И установим собственно пакет и плагин для Firefox:

sudo apt-get install lightspark browser-plugin-lightspark

Обратите внимание, что в списке зависимостей будет и собственно gnash.

Результат теста: следует сказать, что хотя и flash в принципе работает, но браузер очень часто подвисал «намертво», с максимальной загрузкой процессора, в  том числе даже от обыкновенных флеш-баннеров. Поэтому долго тестировать у меня его не получилось.  В результате, рекомендовать для полноценного использования не могу. При этом в пункте about флеш-видео и флеш-роликов, равно как и в «Дополнениях» Firefox, Lightspark идентифицируется как Gnash.

Gnash, название которого происходит от слов GNU и Flash, на основе которого и был создан Lightspark,  в свою очередь берет свое начало от проекта GPLFlash. Gnash продолжает развиваться параллельно  с Lightspark и имеет определенную аудиторию поклонников, в том числе на тех платформах/архитектурах, для которых Adobe не выпустила свой плеер. 
Пакет есть в репозитории Ubuntu и его установка не составит сложности:
sudo aptitude install gnash mozilla-plugin-gnash
Результат теста: пакет работает стабильнее, чем Lightspark, но в моем случае, вероятно наблюдался конфликт с видеосистемой, т.к. при скролинге страниц с флеш-роликами на экране оставался след от них, что весьма часто делало серфинг весьма затруднительным. При этом периодически наблюдалась максимальная загрузка процессора. Как вывод, использовать в качестве постоянной замены Flash — рано.
Swfdec, не смотря на последнее обновление в 2008 году, по праву можно назвать наиболее стабильной заменой Adobe Flash. Хотя ему и не под силу полноценно выводить некоторые ролики, все же с большинством он справляется хорошо, при этом не вызывая сбои в работе браузера и не страдая от чрезмерной загрузки процессора. Именно этот пакет я использую уже весьма продолжительное время, и как оказалось, не зря.
Установить его можно следующей командой: 
sudo aptitude install swfdec-mozilla
 Результат теста: не смотря на то, что пакет не может похвастаться самыми широкими возможностями, на практике оказывается наиболее стабильным.
Решать, что использовать —  вам. И все же, если вы решили отказаться от Adobe Flash, то мой совет — ставьте Swfdec.