Tag Archiv: 64-bit

Adobe Flash 64-bit

Неделю назад назад компания Adobe выпустила бета-версию Flash Player 11 для 64-битных Linux-систем. Напомним, что ранее пользователям Linux  приходилось довольствоваться 32-битной версией или же альтернативными Flash-плеерами.
От новой версии ожидается, в первую очередь, прирост производительности при работе. Кроме того, заявлен ряд новых функций, среди которых  отдельно стоит назвать програмное кодирование H.264.
Пользователи Ubuntu могут установить  Flash Player 11 beta из PPA, выполнив эту команду:

sudo add-apt-repository ppa:sevenmachines/flash && sudo apt-get update && sudo apt-get install flashplugin64-installer

Adobe AIR в Ubuntu 64-bit

Одной из существующих платформ для работы веб-приложений является Adobe AIR. Рано или поздно, возможно, вам придётся столкнуться с одним из таких приложений, которые потребуют установки Adobe AIR.
Если для 32-битной системы особых проблем не возникает при установке AIR с сайта Adobe, то для 64-битной требуется некоторая подготовка. К сожалению, представленный на странице загрузки deb-пакет рассчитан на установку только в 32-битную систему. 

Для установки же в 64-битную систему нам необходимо использовать инсталлятор (bin), предварительно установив поддержку 32-битных библиотек:
sudo apt-get install ia32-libs

После чего, скачаем инсталлятор, и поместим (для удобства) его в домашний каталог.

Поставим права выполнения для файла

chmod 777 ~/AdobeAIRInstaller.bin

и запустим его из домашнего каталога

./AdobeAIRInstaller.bin

После этого вы можете запустить Adobe AIR в меню «Инструменты» и вручную указать предварительно скачанный файл с приложением AIR.

Однако, чтобы избежать ненужных манипуляций, довольно часто предлагается запуск установки сразу со страницы приложения. В этом случае, необходимо указать путь к Adobe AIR.
Рассмотрим это на примере Mozilla Firefox.
При первой загрузке AIR приложения браузер спросит о требуемом действии («Открыть в…» / «Сохранить»). Выберем  приложение в «Открыть в…». Необходимый нам файл находится в /usr/bin/  (см. скриншот ниже)
После выбора установщика для открытия AIR-приложений нажимаем OK.

Установка Zend Optimizer на Ubuntu 64bit

 

Zend Optimizer — единственное приложение компании Zend, распространяемое бесплатно. Являет собой серверный модуль для запуска закодированных с помощью Zend Encoder и Zend SafeGuard Suite скриптов, а также немного их ускоряющий (заявлено, что до 40 %).
Мне потребовалось для установки некоторых модулей под движек DLE версии 9.

Итак начнем, убедимся для начала, что у нас именно 64 разрядная ОС.
#uname -a
Linux red 2.6.31-20-server #58-Ubuntu SMP Fri Mar 12 05:40:05 UTC 2010 x86_64 GNU/Linux
Наличие x86_64 подтверждает наше предположение.

Перейдем в директорию /tmp:
# cd /tmp
Загрузим дистрибутив с сайта производителя для для 64-битных ОС:
# wget http://downloads.zend.com/optimizer/3.3.9/ZendOptimizer-3.3.9-linux-glibc23-x86_64.tar.gz
Распаковываем:
# tar -xzf ZendOptimizer-3.3.9-linux-glibc23-x86_64.tar.gz
Переходим в директорию ZendOptimizer-3.3.9-linux-glibc23-i386:
# cd ZendOptimizer-3.3.9-linux-glibc23-x86_64
Определяем версию PHP
# php -v
Получаем
PHP 5.2.10-2ubuntu6.5 with Suhosin-Patch 0.9.7 (cli) (built: Sep 16 2010 19:48:40)
Соответственно копируем файл для версии 5.2.xx:
# cp -rfv /ZendOptimizer-3.3.9-linux-glibc23-x86_64/data/5_2_x_comp/ZendOptimizer.so /usr/local/Zend/lib
Если такой /usr/local/Zend/lib путь отсутствует, то создаем каталог получения
# mkdir /usr/local/Zend/lib
В файл /etc/php5/apache2/php.ini вносим строки в секцию [Zend]:
[Zend]
zend_extension=/usr/local/Zend/lib/ZendOptimizer.so
Перезапускаем Apache командой:
# service apache2 restart
Вуаля!

Ставим 32-битные библиотеки в 64-битном Ubuntu или Debian

Одним из аргументов против установки 64-битных систем была проблема с некоторыми устаревшими 32-битными программами (обычно проприетарными), и что более важно — с драйверами.
В этой ситуации часто приходится «вручную» находить и скачивать 32-битные библиотеки, создавать сим-линки и т.д.
Для автоматизированного решения такой проблемы существует пакет getlibs, который работает под Ubuntu, debian, а также под клонами этих ОС.

Скачать его можно как у разработчика так и на зеркале.
При скачке пакет можно установить, открыв с помощью Gdebi. Если же этого не произошло, то установить можно при помощи команды
 sudo dpkg -i getlibs-all.deb
Пользоваться программой несложно, и возможно несколькими способами:

1. Установка всех необходимых для 32-битного приложения библиотек:

sudo getlibs /usr/bin/program

где program — имя программы
2. Установить конкретные библиотеки (будут автоматически скачаны из интернета):

sudo getlibs -l library.so.0

3.  Установить по имени пакета (будут автоматически скачаны из интернета):

 sudo getlibs -p library

где library в этом и предыдущих пунктах — имя библиотеки или пакета.
4. Установить 32-битную библиотеку в виде deb-пакета, расположенную по указанному пути на диске:

sudo getlibs -i /home/user/i386_library.deb

5. Установить 32-битную библиотеку по прямой ссылке в интернет:

 getlibs -w http://mirrors.kernel.org/ubuntu/library_i386.deb
Примечание: для того, чтобы установить 32-битную программу (не библиотеку) в 64-битной системе следует воспользоваться параметром —force-all в dpkg:
 sudo dpkg -i —force-all package_name.deb
 Кроме перечисленных основных опций у getlibs есть еще ряд вспомогательных параметров:
—apt-file : поиск имени пакета для библиотек на packages.ubuntu.com. Полезно для не-Ubuntu пользователей.

—build : (бета-функция) конвертирует 32-битный пакет в 64-битный и устанавливает его (только библиотеки). Не рекомендуется к использованию.

—savebuild : используется с  —build. Сохраняет полученный 64-битный пакет в домашний каталог (/home/$USER)

—mirror
или -m : использовать указанное зеркало для поиска библиотек.

—verbose : подробный вывод результатов работы на экран.

—ldconfig :  выполняет ldconfig для каталогов, куда установлены новые библиотеки

-64 : Установка 64-битных пакетов для  64-битных систем

—distro : выбор между  Ubuntu и Debian. Ubuntu устанавливает в  /usr/lib32 и/или  /lib32. Debian устанавливает в /emul/ia32-linux/

—release : допустимы значения hardy gutsy feisty edgy или dapper.
Определяет, какой веб-интерфейс использовать для поиска.